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Library setup and controller configuration manual 
FANUC Robotics Library 

Setup overview 

The setup procedure for DigiMetrix Robotics Library for Fanuc consists of the following steps: 

1. Checking system requirements 

2. Installing DigiMetrix Robotics Library for Fanuc 

3. Configuring robot controller and LabVIEW computer Ethernet connection 

4. Loading server part of the library to the robot controller 

1. (Optional) Uninstalling server programs from the previous version 

2. Locating the appropriate server programs for your controller software version 

3. Upload using the FTP client program FileZilla 

4. Upload using the USB flash drive 

5. Configuring the robot controller variables 

6. Overview of controller settings automatically changed by server program 

5. Initial manual start of server program 

6. Restarting the controller 

Precaution 

Please carefully read the Safety and Installation manual provided by the manufacturer and other related manuals dedicated to 

the installation and setup procedures for the robot system before using it with this library. 

Following manual assumes that qualified personnel performed all the installation procedures for the robot system. 

Checking system requirements 

Please verify the following system requirements. 

FANUC system requirements 

 Fanuc R-30iA (software version 7.5 or later) or R-30iB robot controller 

 Software option User Socket Messaging (R648) installed on Robot Controller. It can be checked on Teach Pendant in  

[Menu] -> [STATUS] -> [TYPE (F1)] -> [Version ID] -> [CONFIG (F3)] 

 For some controller versions (especially versions distributed in USA) also software option (R632) – KAREL is needed. Please 

contact your FANUC representative and ask if this option is needed to run compiled ‘PC’ files on the controller. 

 Server program uses Position registers 1,2,3,4, integer registers 1,2,3,4,5,6,7,8,9,10 and flags 1,2,3. Please make sure that 

no other program running in parallel makes use of this registers and flags. This can cause an unexpected behavior. 

LabVIEW system requirements 

 LabVIEW 2009 or above (32 & 64 bit) 

 Ethernet card and Ethernet cable 

 Microsoft Windows XP, Vista, 7, 8, 8.1, 10 (32 & 64 bit) or LabVIEW Real-Time operating system 

Installing DigiMetrix Robotics Library for Fanuc 

The library installation 

Please use VI Package Manager 2014 or later in order to install the library. 

1. Open JKI VI Package Manager from your Desktop or using LabVIEW menu Tools -> VI Package Manager 
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2. Select Fanuc Robotics Library by DigiMetrix product in the list or open .vip file using top menu command File -> Open 

Package File(s). 

3. Read the library description, select your LabVIEW version and click Install button 

 

Configuring robot controller and LabVIEW computer Ethernet connection 

FANUC robotics library uses TCP/IP communication protocol, robot controller and LabVIEW computer should have 

appropriate TCP/IP connection settings for your network configuration. 

Example below shows possible settings using static addresses. For this configuration Ethernet cable should connect 

robot controller and computer network card directly or using a switch. To set up dynamic address acquisition from 

DHCP server, please refer to your controller documentation. 

Robot controller example TCP/IP settings: 

[Menu] -> [SETUP] -> [TYPE (F1)] -> [Host Comm] ->[TCP/IP]-> [DETAIL (F3)] 
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LabVIEW computer example TCP/IP settings: 

 
Ethernet port location on R-30iB Mate Cabinet controller (view of the opened controller door): 

 
As the result of this configuration step you should be able to ping the controller using address you have assigned.  
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Loading server part of the library to the robot controller 

(Optional) Unistalling server programs from the previous version 

If you are upgrading from previous version of FANUC Robotics Library – you will need to delete existing server programs from 

the robot controller. This needs to be done, because some variable type definitions have changed and an attempt to overwrite 

existing programs will cause errors MEMO-159 and VARS-014 when controller will try to convert those variables. Simply delete 

all server programs (dmbuf, dmcfg, dmcmd, dmlog, dmpkt, dmserver, dmsocket, dmmove) from the Teaching Pendant ([Select]-

>(Navigate to program)->[DELETE(F3)]->[YES(F4)]). 

Also it is possible to delete these programs using FTP (see Upload using the FTP client program FileZilla for details). But please 

note that you will need to delete variable files as well – *.VA and *.VR files with same names as server programs. 

Locating the appropriate server programs for your controller software version 

The server part of the library (set of compiled binaries with PC extension and TP dmmove program) is stored in the following 

location: 

<Public Program Data>\DigiMetrix\Fanuc Robotics Library\Server binaries 

On Windows 8.1 (64-bit) this folder is located in: 

C:\ProgramData\DigiMetrix\Fanuc Robotics Library\Server binaries 

You can easily navigate to this folder by using this command: 

LabVIEW Tools menu -> DigiMetrix Tools -> Fanuc Robotics Library -> Server binaries 

There you can find the following folder structure, where first level corresponds to controller type and the second – to controller 

software version: 

 R-30iA 
o V7.50 
o V7.70 

 R-30iB 
o V8.10 
o V8.13 
o V8.20 
o V8.30 

Pick up the set of files depending on your controller type and software version. Controller software version can be found on 

Teach Pendant in  

[Menu]->[UTILITIES]->[TYPE (F1)]->Hints 

this is usually the startup screen after controller boot up. For the example below the version is 8.20, and the full path to server 

binaries location will be  

LabVIEW Tools menu -> DigiMetrix Tools -> Fanuc Robotics Library -> Server binaries -> R-30iB -> V8.20 

The list of files to be copyed or uploaded to robot controller is: 

1. dmbuf.pc 

2. dmcfg.pc 

3. dmcmd.pc 

4. dmlog.pc 

5. dmpkt.pc 

6. dmserver.pc 

7. dmsocket.pc 

8. dmmove.tp 



 

 

DigiMetrix Robotics Library for Fanuc 
Library setup and controller configuration manual 

Rev. 2 

 

 
DigiMetrix GmbH © 2013-2017 Page 5 
 

The folder also includes dmmove.ls program – it does not need to be uploaded. It is distributed for the case you will need to do 

some specific changes with library configuration, like changing register numbers used by the library.  

 

Upload using the FTP client program FileZilla 

You can upload programs on the robot controller using any FTP client program, which supports DOS mode. As an example 

FileZilla FTP client program is used in the steps below. FTP server should be set up and enabled on robot controller. At most 

cases it is setup and enabled by default. FTP server configuration can be found on Teach Pendant in: 

[Menu]->[SETUP]->[TYPE (F1)]->[Host Comm]->[SHOW (F4)] -> Servers 

Please refer to controller setup manual for accurate steps on FTP server configuration.  

Start FileZilla, open File -> Site Manager, then configure the FTP connection to the robot. Set appropriate IP address (the one set 

in step 3), user name and password (if ones are configured), default username is anonymous with empty password. Then please 

open the Advanced tab and select Server Type: DOS.  
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Then click connect, locate server binaries on the left pane and select them, then copy them on server by simply dragging files to 

the right pane or by doing Right Click on selected files -> Upload. 

 

Using the USB flash drive 

You can use USB flash drive to copy server files on the robot controller. You fill need a FAT32 formatted flash drive. It is 

recommended to use one less or equal than 4 GB. Copy the appropriate files to the root of empty flash drive, plug it into the 

robot controller, then navigate on Teach Pendant to: 

 [Menu] -> [FILE] -> [UTIL (F5)] -> Set Device -> Select USB Disk (UD1:) 

then navigate to 

 [Next] -> [COPY] 

Then in line To Device select (by clicking [CHOISE]) Mem Device MD: and click [DO_COPY (F1)]. 
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Configuring the robot controller variables 

The main server program is DMSERVER.PC, all other files are used by this one. At the first start it does configuration of the 

controller variables needed for communication and automatic startup at the controller boot. But for the first time, you need to 

start it manually, in order to do that, first please adjust one controller variable in order to allow KAREL (ones with PC extension) 

programs to show up in Teach Pendant menu. Navigate on Teach Pendant to: 

 [Menu] -> [SYSTEM] -> [TYPE (F1)] -> Variables 

Then locate the $KAREL_ENB variable and set it to 1. 

Overview of controller settings automatically changed by server program 

At the first start DMSERVER program sets the following controller variables: 

$SHELL_CFG.$SHELL_EXT = FALSE 

$SHELL_CFG.$SHELL_NAME = ‘DMSERVER’ 

$SHELL_WRK.$KAREL_SOP = TRUE 

$HOSTS_CFG[4].$COMMENT = 'DM_FcRL_Svr' 

$HOSTS_CFG[4].$PROTOCOL = ‘SM’ 

$HOSTS_CFG[4].$SERVER_PORT = 10000 

$HOSTS_CFG[4].$OPER = 3 

$HOSTS_CFG[4].$TIMEOUT = 9999 

These settings install DMSERVER program as shell program and configure server Tag 4 (S4) to be used as Socket Messaging 

server on port 10000. Please note that setting $SHELL_CFG.$SHELL_EXT = FALSE will not allow you to use RSR to start 

programs. If your system requires to use RSR or you would like to change the Tag number, server port or change the register 

numbers and numbers of flags used by server, please refer to Changing the default server settings section, before you perform 

the initial manual start of server program DMSERVER. 

Initial manual start of server program 

Navigate on Teach Pendant to: 

[Select] -> [TYPE (F1)] -> KAREL Progs (or All) 

Then locate the DMSERVER program and select it by clicking Enter. ‘DMSERVER is selected’ should appear on the bottom of 

Teach Pendant screen. Then start it. You can do it in Teach Mode by holding Shift button and clicking FWD, or in Auto mode by 

pushing Cycle Start button. 

Restarting the controller 

After the steps above please Cold Start the controller, you should see the messages on Teach Pendant like on the screenshot 

below: 
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Next steps  

Now your robot controller is configured. We suggest you start with library examples. Please refer to the Getting Started help 

topic. 

Changing the default server settings 

If your system does not allow to use default server settings, please refer to the steps below on adjusting the settings. Please be 

careful, do it at your own risk, and do not change any other DMSERVER variables, except of ones described below. Most of the 

steps need to perform ‘Navigate to DMSERVER settings’ procedure, which is described below: 

On Teach Pendant, navigate to: 

[Select] -> [TYPE (F1)] -> KAREL Progs  

Select the DMSERVER program, click Enter, ‘DMSERVER is selected’ should appear at the bottom of Teach Pendant screen, then  

Navigate to 

[Data] -> [TYPE (F1)] -> KAREL Vars 

Select the CFG_ variable of type DMSVRCFG_T, click enter, a list of setting variables will appear. 

I need to use RSR 

If you need to use RSR, then you need to disable installation of DMSERVER as a shell program, but, at this case, it will not be 

automatically started at the controller boot up. You will need to start it before using the LabVIEW library VIs: manually, or using 

PNS or RSR, or in any other way suitable for your system. To disable installation as a shell program, please navigate to 

DMSERVER settings (as described above), find the SET_SHELL variable and set it to FALSE. Then please perform the initial start of 

DMSERVER program. 

I want to change server tag number 

To change server tag number, please navigate to DMSERVER settings (as described above), find the S_TAG_NUM variable and 

set it to desired tag number within range 1..8. Then please perform the initial start of DMSERVER program. 

I want to change server port number 

To change server port number, please navigate to DMSERVER settings (as described above), find the S_TCP_PORT variable and 

set it to desired port number. Then please perform the initial start of DMSERVER program. 

I want to change numbers of registers and flags used by server program 

For robot motion server uses a DMMOVE.TP program (called Toolkit hereafter) and, by default, uses position registers 1,2,3,4, 

integer registers 1,2,3,4,5,6,7,8,9,10 and flags 1,2,3 for communication with Toolkit. Changing numbers of registers is a bit more 

complicated since it needs to change them in both DMSERVER and DMMOVE programs. Please contact DigiMetrix support 

support@digimetrix.com to get detailed instructions on how to accomplish that. 

I have performed the initial start of DMSERVER program and I want to reconfigure 

If you want to change the server settings, please 

1. Shut down DMSERVER if it is currently running by clicking on Teach Pendant 

[Fctn] -> ABORT (All) 

Double-clicking ABORT may be needed if server is in ‘Waiting for client’ state 

2. Do the desired changes as described abobe 

3. Navigate to DMSERVER settings (as described above) 

4. Then find the SCK_INIT variable and set it to TRUE 

5. Manually start DMSERVER program 
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